NEC EXPRESSCLUSTER X Old API Server 0x1D Stack Overflow

EIP-2015-0015

A stack-based buffer overflow has been found in NEC EXPRESSCLUSTER X that can lead to remote arbitrary code execution with full SYSTEM privileges. The Old API Support service (clpoldapi.exe) is the system service component tasked with backwards compatibility and utilizes a random port between 1000 and 1500. This vulnerability occurs during the processing of opcode 0x1D within the Old API service. An attacker is able to introduce crafted data into the clptrnsv service to allow for arbitrary code execution.

Vulnerability Identifiers

  • Exodus Intelligence: EIP-2015-0015
  • MITRE CVE: CVE-2021-20704

Vulnerability Metrics

  • CVSSv2 Score: 10.0

Vendor References

Discovery Credit

  • Exodus Intelligence

Disclosure Timeline

  • Disclosed to affected vendor: February 25th, 2021
  • Disclosed to public: October 29th, 2021

Further Information

Readers of this advisory who are interested in receiving further details around the vulnerability, mitigations, detection guidance, and more can contact us at sales@exodusintel.com.

Researchers who are interested in monetizing their 0Day and NDay can work with us through our Research Sponsorship Program.